#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0*(?:[1-9]\d{0,3})?(?:\.0*(?:[1-9]\d{0,3})?)?$"
Local $sString = "123.4" & @CRLF & _
"12.34" & @CRLF & _
"1.2" & @CRLF & _
"223" & @CRLF & _
"0.1234" & @CRLF & _
"0.000001234" & @CRLF & _
"00." & @CRLF & _
"0012345.824989" & @CRLF & _
"0000.000000001234" & @CRLF & _
"0000.0000000012348" & @CRLF & _
".090" & @CRLF & _
"001111.000001111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")