$re = '/^0*(?:[1-9]\d{0,3})?(?:\.0*(?:[1-9]\d{0,3})?)?$/m';
$str = '123.4
12.34
1.2
223
0.1234
0.000001234
00.
0012345.824989
0000.000000001234
0000.0000000012348
.090
001111.000001111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);