const regex = /^0*(?:[1-9]\d{0,3})?(?:\.0*(?:[1-9]\d{0,3})?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0*(?:[1-9]\\d{0,3})?(?:\\.0*(?:[1-9]\\d{0,3})?)?$', 'gm')
const str = `123.4
12.34
1.2
223
0.1234
0.000001234
00.
0012345.824989
0000.000000001234
0000.0000000012348
.090
001111.000001111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}