use strict;
my $str = 'MATCH:
foo123@gmail.com
a22oo@hotmail.com
hoo567@outlook.com
1@
20@ 30@ 40@ 50@
100@
0000@ 1000@ 1800@ 2100@ 2200@ 3000@ 4000@ 5000@ 6000@ 7000@ 8000@ 9000@
10000@test.com
100000@
NOT MATCH:
foo@gmail.com
johndoe88@hotmail.com
john1976@outlook.com
00@ 10@ 60@ 70@ 80@ 90@
1900@ 2000@';
my $regex = qr/(\b|[^\d\s])(\d|[2345]\d|\d{3}|(1[^9]|2[^0]|[03-9]\d)\d\d|\d{5,})(\D*?@|@)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}