$re = '/(\b|[^\d\s])(\d|[2345]\d|\d{3}|(1[^9]|2[^0]|[03-9]\d)\d\d|\d{5,})(\D*?@|@)/';
$str = 'MATCH:
foo123@gmail.com
a22oo@hotmail.com
hoo567@outlook.com
1@
20@ 30@ 40@ 50@
100@
0000@ 1000@ 1800@ 2100@ 2200@ 3000@ 4000@ 5000@ 6000@ 7000@ 8000@ 9000@
10000@test.com
100000@
NOT MATCH:
foo@gmail.com
johndoe88@hotmail.com
john1976@outlook.com
00@ 10@ 60@ 70@ 80@ 90@
1900@ 2000@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);