// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\b|[^\d\s])(\d|[2345]\d|\d{3}|(1[^9]|2[^0]|[03-9]\d)\d\d|\d{5,})(\D*?@|@)").unwrap();
let string = "MATCH:
foo123@gmail.com
a22oo@hotmail.com
hoo567@outlook.com
1@
20@ 30@ 40@ 50@
100@
0000@ 1000@ 1800@ 2100@ 2200@ 3000@ 4000@ 5000@ 6000@ 7000@ 8000@ 9000@
10000@test.com
100000@
NOT MATCH:
foo@gmail.com
johndoe88@hotmail.com
john1976@outlook.com
00@ 10@ 60@ 70@ 80@ 90@
1900@ 2000@";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}