# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!href="|">)(https?:\\/\\/[\w\-\.!~?&=+\*\'(),\\/]+)((?!\<\\/\a\>).)*/<a href="$1">$1<\/a>/gm;t' <<< "Test,
Here\'s an interesting in-house litigation position with JPMorgan Chase in New York I thought you might be interested inL
<a href=\"http://www.xxx.com/lcdetail.php?akey=e1725\">http://www.xxx.com/lcdetail.php?akey=e1725</a>
They are not using recruiters to fill this job, so if you are interested you can just apply directly.
http://www.xxx.com/lcdetail.php?akey=e1725
Cordially
--Harrison"