using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!href=""|"">)(https?:\/\/[\w\-\.!~?&=+\*\'(),\/]+)((?!\<\/\a\>).)*";
string substitution = @"<a href=""$1"">$1</a>";
string input = @"Test,
Here\'s an interesting in-house litigation position with JPMorgan Chase in New York I thought you might be interested inL
<a href=""http://www.xxx.com/lcdetail.php?akey=e1725"">http://www.xxx.com/lcdetail.php?akey=e1725</a>
They are not using recruiters to fill this job, so if you are interested you can just apply directly.
http://www.xxx.com/lcdetail.php?akey=e1725
Cordially
--Harrison";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}