import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!href=\"|\">)(https?:\\/\\/[\\w\\-\\.!~?&=+\\*\\'(),\\/]+)((?!\\<\\/\\a\\>).)*";
final String string = "Test,\n\n"
+ "Here\\'s an interesting in-house litigation position with JPMorgan Chase in New York I thought you might be interested inL\n\n"
+ "<a href=\"http://www.xxx.com/lcdetail.php?akey=e1725\">http://www.xxx.com/lcdetail.php?akey=e1725</a>\n\n"
+ "They are not using recruiters to fill this job, so if you are interested you can just apply directly. \n\n"
+ "http://www.xxx.com/lcdetail.php?akey=e1725\n\n"
+ "Cordially\n"
+ "--Harrison";
final String subst = "<a href=\"$1\">$1</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}