#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((https?)?([^\/])*)"
Local $sString = "http://www.christianliferesources.com/links.html" & @CRLF & _
"google.com" & @CRLF & _
"http://dhhs.ne.gov/publichealth/Pages/hew_hpe_nebraskacares_resources.aspx" & @CRLF & _
"http://www.babysittersguide.mobi/resources/links.php" & @CRLF & _
"http://www.lifeslittletreasures.org.au/prematurity/useful-links/" & @CRLF & _
"http://www.rms.org.uk/outreach/index/WebLinks" & @CRLF & _
"http://www.cellbiolabs.com/links-resources" & @CRLF & _
"http://nationalcmlsociety.org/resources/cml-and-leukemia-links" & @CRLF & _
"http://lifeslittletreasures.org.au/prematurity/useful-links/" & @CRLF & _
"https://www.aps-spr.org/resources/helpful-links.asp" & @CRLF & _
"http://www.womeningovernment.org/oncology/hpv/resources/online" & @CRLF & _
"http://www.lymphoma.ca/lymphoma/resources/helpful-links" & @CRLF & _
"http://www.nationalcmlsociety.org/resources/cml-and-leukemia-links" & @CRLF & _
"https://www.lymphoma.ca/lymphoma/resources/helpful-links" & @CRLF & _
"http://www.cyagen.com/us/en/resources/useful-links.html" & @CRLF & _
"http://womeningovernment.org/oncology/hpv/resources/online" & @CRLF & _
"http://www.citykinder.com/for-parents-to-be/links-we-like/" & @CRLF & _
"https://www.womeningovernment.org/oncology/hpv/resources/online" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=89" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272" & @CRLF & _
"http://www.christianliferesources.com/links.html?print=1" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=88" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=88" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=88" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=268" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=263" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=268" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=266" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=90" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=86" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=263" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=94" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=94" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=86" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=265" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=85" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=263" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=266" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=264" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=87" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=91" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=92" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=91" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=87" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=263" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=94" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=94" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=86" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=267" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=264" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=265" & @CRLF & _
"http://www.transfusionmedicine.ca/resources/links/Web-Links" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=264" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=93" & @CRLF & _
"http://www.easierparenting.com.au/resources/useful-links/" & @CRLF & _
"http://www.swedishamerican.org/services/cancer_care/links/" & @CRLF & _
"http://chd.org/adult-services/community-based-programs/cancer-house-hope/helpful-linksresources/" & @CRLF & _
"http://www.aps-spr.org/resources/helpful-links.asp" & @CRLF & _
"http://www.cyagen.com/us/ja/resources/useful-links.html" & @CRLF & _
"https://www.transfusionmedicine.ca/resources/links/Web-Links" & @CRLF & _
"http://www.communityoptions.ab.ca/resources/helpful-links" & @CRLF & _
"https://www.lifeslittletreasures.org.au/prematurity-resources/useful-links/" & @CRLF & _
"http://www.lifeslittletreasures.org.au/prematurity-resources/useful-links/" & @CRLF & _
"https://www.rmhca.org/family-resources/helpful-links-for-families/" & @CRLF & _
"http://lifeslittletreasures.org.au/prematurity-resources/useful-links/" & @CRLF & _
"http://www.americantransplantfoundation.org/about-transplant/resources-and-links/other-organizations/" & @CRLF & _
"http://perinatalresources.org/medical-education-links/" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=268" & @CRLF & _
"http://www.losninos.com/resources/helpful-links/" & @CRLF & _
"http://swedishamerican.org/services/cancer_care/links/" & @CRLF & _
"http://fitwise.com.au/patient-resources/links-page" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=87" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=91" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=90" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=91" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=89" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=266" & @CRLF & _
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=93" & @CRLF & _
"http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=88" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=90" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=93" & @CRLF & _
"http://www.hospicegiving.org/resources-links" & @CRLF & _
"http://www.transfusionmedicine.ca/resources/links/web-links/itranfuse-australian-red-cross-blood-service" & @CRLF & _
"http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks" & @CRLF & _
"http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=85" & @CRLF & _
"http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=90" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=92" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=87" & @CRLF & _
"http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=84" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=84" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=267" & @CRLF & _
"http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=81" & @CRLF & _
"http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=81" & @CRLF & _
"http://www.choicespregnancypartners.org/national-affiliates" & @CRLF & _
"https://www.choicespregnancypartners.org/national-affiliates" & @CRLF & _
"http://www.transfusionmedicine.ca/resources/links/web-links/cord-blood-center" & @CRLF & _
"https://www.transfusionmedicine.ca/resources/links/web-links/cord-blood-center" & @CRLF & _
"http://advantacare.net/Resource-Center/Medical-Web-Sites" & @CRLF & _
"http://www.ncpeid.org/index.php/links-resources" & @CRLF & _
"http://www.transfusionmedicine.ca/fr/resources/links/Web-Links" & @CRLF & _
"https://www.transfusionmedicine.ca/fr/resources/links/Web-Links" & @CRLF & _
"http://www.idahoperinatal.org/links.php" & @CRLF & _
"http://www.transfusionmedicine.ca/resources/links/web-links/american-association-blood-banks-aabb" & @CRLF & _
"https://www.transfusionmedicine.ca/fr/resources/links/web-links/itranfuse-australian-red-cross-blood-service" & @CRLF & _
"http://ncpeid.org/index.php/links-resources/for-parents" & @CRLF & _
"http://www.transfusionmedicine.ca/fr/resources/links/web-links/american-association-blood-banks-aabb" & @CRLF & _
"http://www.transfusionmedicine.ca/fr/resources/links/web-links/itranfuse-australian-red-cross-blood-service" & @CRLF & _
"https://www.transfusionmedicine.ca/resources/links/web-links/itranfuse-australian-red-cross-blood-service" & @CRLF & _
"http://ncpeid.org/index.php/links-resources" & @CRLF & _
"http://idahoperinatal.org/links.php" & @CRLF & _
"http://www.soulchoice.org/links.html" & @CRLF & _
"http://www.soulchoice.org/online-resources-and-helpful-links.html" & @CRLF & _
"http://www.horsepowerforlife.org/resources/useful-links/" & @CRLF & _
"http://www.fertilityresourceshouston.com/additional-information/helpful-links.aspx" & @CRLF & _
"http://www.horsepowerforlife.org/index.php/resources/useful-links/" & @CRLF & _
"http://www.sri-online.org/links/educational-resources" & @CRLF & _
"http://www.rmhca.org/family-resources/helpful-links-for-families/" & @CRLF & _
"https://perinatalresources.org/medical-education-links/" & @CRLF & _
"http://aohna.org/resources-links/ohn-resources" & @CRLF & _
"http://ichpcolorado.com/services/Links_to_National_Health_Care_Resources.htm" & @CRLF & _
"http://www.healthystartbfg.com/Resources-Links.aspx" & @CRLF & _
"http://healthystartbfg.com/Resources-Links.aspx" & @CRLF & _
"http://www.ichpcolorado.com/services/Links_to_National_Health_Care_Resources.htm" & @CRLF & _
"http://tkeckle.net/links/medical.html" & @CRLF & _
"http://leavenfortheloaf.com/links/crisis-pregnancy-resources-in-nh/comment-page-1/#comments" & @CRLF & _
"http://leavenfortheloaf.com/links/crisis-pregnancy-resources-in-nh/" & @CRLF & _
"http://www.fitwise.com.au/patient-resources/links-page" & @CRLF & _
"http://www.parentingmatters-epc.org/parent-resources-support/helpful-links/" & @CRLF & _
"http://www.lifeslittletreasures.com.au/prematurity/useful-links/" & @CRLF & _
"http://leukodystrophyresourceresearch.org/resources-news/useful-links/" & @CRLF & _
"http://www.centralvalleymedicalcenter.com/resources/helpful-links" & @CRLF & _
"https://www.achancetogrowfilm.com/resources/resource-links/" & @CRLF & _
"http://wallofcourage.com/links/index.htm" & @CRLF & _
"http://www.wallofcourage.com/links/index.htm" & @CRLF & _
"http://myoc3.org/directory/catalog/companies/293?task=companies.showCompanyWebsite" & @CRLF & _
"http://www.myoc3.org/component/jbusinessdirectory/companies/293?task=companies.showCompanyWebsite" & @CRLF & _
"http://myoc3.org/component/jbusinessdirectory/companies/293?task=companies.showCompanyWebsite" & @CRLF & _
"http://www.arearlylearning.org/index.php/parents/parent-links/12" & @CRLF & _
"http://www.designedtobirth.com/links-books-and-resources.html" & @CRLF & _
"http://www.myoc3.org/directory/catalog/companies/293?task=companies.showCompanyWebsite" & @CRLF & _
"http://frontrangeobgyn.com/resources/links/" & @CRLF & _
"http://arearlylearning.org/index.php/parents/parent-links/12" & @CRLF & _
"http://www.arearlylearning.org/index.php/parents/parent-links?task=weblink.go&id=12" & @CRLF & _
"http://movingbeyondcancer.com.au/useful-links?task=weblink.go&id=14" & @CRLF & _
"http://www.motherandbabymatters.com/resources.html" & @CRLF & _
"http://arearlylearning.org/index.php/parents/parent-links?task=weblink.go&id=12" & @CRLF & _
"http://au.sascentre.com/resources/1323" & @CRLF & _
"http://int.sascentre.com/resources/1323" & @CRLF & _
"http://uk.sascentre.com/resources/1323" & @CRLF & _
"http://www.koruselfdevelopment.com/index.php/links/16" & @CRLF & _
"http://koruselfdevelopment.com/index.php/links/16" & @CRLF & _
"http://msoncologysociety.org/links-resources.php" & @CRLF & _
"http://www.msoncologysociety.org/links-resources.php" & @CRLF & _
"http://www.lifeslittletreasures.com.au/prematurity-resources/useful-links/" & @CRLF & _
"http://momchd.com/parenting-links-and-resources/" & @CRLF & _
"http://flintobgyn.com/patient-resources/links/" & @CRLF & _
"http://www.oxfordobgyninc.com/resources/related-links" & @CRLF & _
"http://livehealthysiouxland.org/web-links/8-prevention/73-cord-blood-banking.html" & @CRLF & _
"http://www.livehealthysiouxland.org/web-links/8-prevention/73-cord-blood-banking.html" & @CRLF & _
"http://getready4baby.com/links.html" & @CRLF & _
"http://www.getready4baby.com/links.html" & @CRLF & _
"http://jesperson.se/test1/magpierss/scripts/cache/43521fb1322467036d3b55ea1d37a921" & @CRLF & _
"http://jesperson.se/test1/magpierss/scripts/cache/43521fb1322467036d3b55ea1d37a921" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")