import re
regex = re.compile(r"((https?)?([^\/])*)", flags=re.IGNORECASE)
test_str = ("http://www.christianliferesources.com/links.html\n"
"google.com\n"
"http://dhhs.ne.gov/publichealth/Pages/hew_hpe_nebraskacares_resources.aspx\n"
"http://www.babysittersguide.mobi/resources/links.php\n"
"http://www.lifeslittletreasures.org.au/prematurity/useful-links/\n"
"http://www.rms.org.uk/outreach/index/WebLinks\n"
"http://www.cellbiolabs.com/links-resources\n"
"http://nationalcmlsociety.org/resources/cml-and-leukemia-links\n"
"http://lifeslittletreasures.org.au/prematurity/useful-links/\n"
"https://www.aps-spr.org/resources/helpful-links.asp\n"
"http://www.womeningovernment.org/oncology/hpv/resources/online\n"
"http://www.lymphoma.ca/lymphoma/resources/helpful-links\n"
"http://www.nationalcmlsociety.org/resources/cml-and-leukemia-links\n"
"https://www.lymphoma.ca/lymphoma/resources/helpful-links\n"
"http://www.cyagen.com/us/en/resources/useful-links.html\n"
"http://womeningovernment.org/oncology/hpv/resources/online\n"
"http://www.citykinder.com/for-parents-to-be/links-we-like/\n"
"https://www.womeningovernment.org/oncology/hpv/resources/online\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=89\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272\n"
"http://www.christianliferesources.com/links.html?print=1\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=88\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=88\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=88\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=268\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=263\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=268\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=266\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=90\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=86\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=263\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=94\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=94\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=86\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=265\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=85\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=263\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=266\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=264\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=87\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=91\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=92\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=91\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=87\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=263\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=94\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=94\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=86\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=267\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=264\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=265\n"
"http://www.transfusionmedicine.ca/resources/links/Web-Links\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=264\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=93\n"
"http://www.easierparenting.com.au/resources/useful-links/\n"
"http://www.swedishamerican.org/services/cancer_care/links/\n"
"http://chd.org/adult-services/community-based-programs/cancer-house-hope/helpful-linksresources/\n"
"http://www.aps-spr.org/resources/helpful-links.asp\n"
"http://www.cyagen.com/us/ja/resources/useful-links.html\n"
"https://www.transfusionmedicine.ca/resources/links/Web-Links\n"
"http://www.communityoptions.ab.ca/resources/helpful-links\n"
"https://www.lifeslittletreasures.org.au/prematurity-resources/useful-links/\n"
"http://www.lifeslittletreasures.org.au/prematurity-resources/useful-links/\n"
"https://www.rmhca.org/family-resources/helpful-links-for-families/\n"
"http://lifeslittletreasures.org.au/prematurity-resources/useful-links/\n"
"http://www.americantransplantfoundation.org/about-transplant/resources-and-links/other-organizations/\n"
"http://perinatalresources.org/medical-education-links/\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=268\n"
"http://www.losninos.com/resources/helpful-links/\n"
"http://swedishamerican.org/services/cancer_care/links/\n"
"http://fitwise.com.au/patient-resources/links-page\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=87\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=91\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=90\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=91\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=89\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=266\n"
"http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=93\n"
"http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=88\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=90\n"
"http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=93\n"
"http://www.hospicegiving.org/resources-links\n"
"http://www.transfusionmedicine.ca/resources/links/web-links/itranfuse-australian-red-cross-blood-service\n"
"http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks\n"
"http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks\n"
"http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=85\n"
"http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=90\n"
"http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=92\n"
"http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=87\n"
"http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=84\n"
"http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=84\n"
"http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=267\n"
"http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=81\n"
"http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=81\n"
"http://www.choicespregnancypartners.org/national-affiliates\n"
"https://www.choicespregnancypartners.org/national-affiliates\n"
"http://www.transfusionmedicine.ca/resources/links/web-links/cord-blood-center\n"
"https://www.transfusionmedicine.ca/resources/links/web-links/cord-blood-center\n"
"http://advantacare.net/Resource-Center/Medical-Web-Sites\n"
"http://www.ncpeid.org/index.php/links-resources\n"
"http://www.transfusionmedicine.ca/fr/resources/links/Web-Links\n"
"https://www.transfusionmedicine.ca/fr/resources/links/Web-Links\n"
"http://www.idahoperinatal.org/links.php\n"
"http://www.transfusionmedicine.ca/resources/links/web-links/american-association-blood-banks-aabb\n"
"https://www.transfusionmedicine.ca/fr/resources/links/web-links/itranfuse-australian-red-cross-blood-service\n"
"http://ncpeid.org/index.php/links-resources/for-parents\n"
"http://www.transfusionmedicine.ca/fr/resources/links/web-links/american-association-blood-banks-aabb\n"
"http://www.transfusionmedicine.ca/fr/resources/links/web-links/itranfuse-australian-red-cross-blood-service\n"
"https://www.transfusionmedicine.ca/resources/links/web-links/itranfuse-australian-red-cross-blood-service\n"
"http://ncpeid.org/index.php/links-resources\n"
"http://idahoperinatal.org/links.php\n"
"http://www.soulchoice.org/links.html\n"
"http://www.soulchoice.org/online-resources-and-helpful-links.html\n"
"http://www.horsepowerforlife.org/resources/useful-links/\n"
"http://www.fertilityresourceshouston.com/additional-information/helpful-links.aspx\n"
"http://www.horsepowerforlife.org/index.php/resources/useful-links/\n"
"http://www.sri-online.org/links/educational-resources\n"
"http://www.rmhca.org/family-resources/helpful-links-for-families/\n"
"https://perinatalresources.org/medical-education-links/\n"
"http://aohna.org/resources-links/ohn-resources\n"
"http://ichpcolorado.com/services/Links_to_National_Health_Care_Resources.htm\n"
"http://www.healthystartbfg.com/Resources-Links.aspx\n"
"http://healthystartbfg.com/Resources-Links.aspx\n"
"http://www.ichpcolorado.com/services/Links_to_National_Health_Care_Resources.htm\n"
"http://tkeckle.net/links/medical.html\n"
"http://leavenfortheloaf.com/links/crisis-pregnancy-resources-in-nh/comment-page-1/#comments\n"
"http://leavenfortheloaf.com/links/crisis-pregnancy-resources-in-nh/\n"
"http://www.fitwise.com.au/patient-resources/links-page\n"
"http://www.parentingmatters-epc.org/parent-resources-support/helpful-links/\n"
"http://www.lifeslittletreasures.com.au/prematurity/useful-links/\n"
"http://leukodystrophyresourceresearch.org/resources-news/useful-links/\n"
"http://www.centralvalleymedicalcenter.com/resources/helpful-links\n"
"https://www.achancetogrowfilm.com/resources/resource-links/\n"
"http://wallofcourage.com/links/index.htm\n"
"http://www.wallofcourage.com/links/index.htm\n"
"http://myoc3.org/directory/catalog/companies/293?task=companies.showCompanyWebsite\n"
"http://www.myoc3.org/component/jbusinessdirectory/companies/293?task=companies.showCompanyWebsite\n"
"http://myoc3.org/component/jbusinessdirectory/companies/293?task=companies.showCompanyWebsite\n"
"http://www.arearlylearning.org/index.php/parents/parent-links/12\n"
"http://www.designedtobirth.com/links-books-and-resources.html\n"
"http://www.myoc3.org/directory/catalog/companies/293?task=companies.showCompanyWebsite\n"
"http://frontrangeobgyn.com/resources/links/\n"
"http://arearlylearning.org/index.php/parents/parent-links/12\n"
"http://www.arearlylearning.org/index.php/parents/parent-links?task=weblink.go&id=12\n"
"http://movingbeyondcancer.com.au/useful-links?task=weblink.go&id=14\n"
"http://www.motherandbabymatters.com/resources.html\n"
"http://arearlylearning.org/index.php/parents/parent-links?task=weblink.go&id=12\n"
"http://au.sascentre.com/resources/1323\n"
"http://int.sascentre.com/resources/1323\n"
"http://uk.sascentre.com/resources/1323\n"
"http://www.koruselfdevelopment.com/index.php/links/16\n"
"http://koruselfdevelopment.com/index.php/links/16\n"
"http://msoncologysociety.org/links-resources.php\n"
"http://www.msoncologysociety.org/links-resources.php\n"
"http://www.lifeslittletreasures.com.au/prematurity-resources/useful-links/\n"
"http://momchd.com/parenting-links-and-resources/\n"
"http://flintobgyn.com/patient-resources/links/\n"
"http://www.oxfordobgyninc.com/resources/related-links\n"
"http://livehealthysiouxland.org/web-links/8-prevention/73-cord-blood-banking.html\n"
"http://www.livehealthysiouxland.org/web-links/8-prevention/73-cord-blood-banking.html\n"
"http://getready4baby.com/links.html\n"
"http://www.getready4baby.com/links.html\n"
"http://jesperson.se/test1/magpierss/scripts/cache/43521fb1322467036d3b55ea1d37a921\n"
"http://jesperson.se/test1/magpierss/scripts/cache/43521fb1322467036d3b55ea1d37a921\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")