const regex = /((https?)?([^\/])*)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((https?)?([^\\\/])*)', 'gi')
const str = `http://www.christianliferesources.com/links.html
google.com
http://dhhs.ne.gov/publichealth/Pages/hew_hpe_nebraskacares_resources.aspx
http://www.babysittersguide.mobi/resources/links.php
http://www.lifeslittletreasures.org.au/prematurity/useful-links/
http://www.rms.org.uk/outreach/index/WebLinks
http://www.cellbiolabs.com/links-resources
http://nationalcmlsociety.org/resources/cml-and-leukemia-links
http://lifeslittletreasures.org.au/prematurity/useful-links/
https://www.aps-spr.org/resources/helpful-links.asp
http://www.womeningovernment.org/oncology/hpv/resources/online
http://www.lymphoma.ca/lymphoma/resources/helpful-links
http://www.nationalcmlsociety.org/resources/cml-and-leukemia-links
https://www.lymphoma.ca/lymphoma/resources/helpful-links
http://www.cyagen.com/us/en/resources/useful-links.html
http://womeningovernment.org/oncology/hpv/resources/online
http://www.citykinder.com/for-parents-to-be/links-we-like/
https://www.womeningovernment.org/oncology/hpv/resources/online
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=89
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272
http://www.christianliferesources.com/links.html?print=1
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=88
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=88
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=88
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=268
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=263
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=268
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=266
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=90
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=86
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=263
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=94
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=94
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=86
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=265
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=85
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=263
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=266
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=264
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=87
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=91
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=92
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=91
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=87
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=263
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=94
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=94
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=86
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=267
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=264
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=265
http://www.transfusionmedicine.ca/resources/links/Web-Links
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=264
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=93
http://www.easierparenting.com.au/resources/useful-links/
http://www.swedishamerican.org/services/cancer_care/links/
http://chd.org/adult-services/community-based-programs/cancer-house-hope/helpful-linksresources/
http://www.aps-spr.org/resources/helpful-links.asp
http://www.cyagen.com/us/ja/resources/useful-links.html
https://www.transfusionmedicine.ca/resources/links/Web-Links
http://www.communityoptions.ab.ca/resources/helpful-links
https://www.lifeslittletreasures.org.au/prematurity-resources/useful-links/
http://www.lifeslittletreasures.org.au/prematurity-resources/useful-links/
https://www.rmhca.org/family-resources/helpful-links-for-families/
http://lifeslittletreasures.org.au/prematurity-resources/useful-links/
http://www.americantransplantfoundation.org/about-transplant/resources-and-links/other-organizations/
http://perinatalresources.org/medical-education-links/
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=268
http://www.losninos.com/resources/helpful-links/
http://swedishamerican.org/services/cancer_care/links/
http://fitwise.com.au/patient-resources/links-page
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=87
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=91
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=90
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=91
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=89
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=266
http://tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=93
http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=88
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=90
http://www.tipslimited.co.uk/index.php?option=com_weblinks&view=weblink&id=272&Itemid=93
http://www.hospicegiving.org/resources-links
http://www.transfusionmedicine.ca/resources/links/web-links/itranfuse-australian-red-cross-blood-service
http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks
http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks
http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=85
http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=90
http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=92
http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=87
http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=84
http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=84
http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=267
http://tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=81
http://www.tipslimited.co.uk/index.php?view=weblink&catid=93%3Acord-blood-banking&id=272%3Acordbloodbankingcom&option=com_weblinks&Itemid=81
http://www.choicespregnancypartners.org/national-affiliates
https://www.choicespregnancypartners.org/national-affiliates
http://www.transfusionmedicine.ca/resources/links/web-links/cord-blood-center
https://www.transfusionmedicine.ca/resources/links/web-links/cord-blood-center
http://advantacare.net/Resource-Center/Medical-Web-Sites
http://www.ncpeid.org/index.php/links-resources
http://www.transfusionmedicine.ca/fr/resources/links/Web-Links
https://www.transfusionmedicine.ca/fr/resources/links/Web-Links
http://www.idahoperinatal.org/links.php
http://www.transfusionmedicine.ca/resources/links/web-links/american-association-blood-banks-aabb
https://www.transfusionmedicine.ca/fr/resources/links/web-links/itranfuse-australian-red-cross-blood-service
http://ncpeid.org/index.php/links-resources/for-parents
http://www.transfusionmedicine.ca/fr/resources/links/web-links/american-association-blood-banks-aabb
http://www.transfusionmedicine.ca/fr/resources/links/web-links/itranfuse-australian-red-cross-blood-service
https://www.transfusionmedicine.ca/resources/links/web-links/itranfuse-australian-red-cross-blood-service
http://ncpeid.org/index.php/links-resources
http://idahoperinatal.org/links.php
http://www.soulchoice.org/links.html
http://www.soulchoice.org/online-resources-and-helpful-links.html
http://www.horsepowerforlife.org/resources/useful-links/
http://www.fertilityresourceshouston.com/additional-information/helpful-links.aspx
http://www.horsepowerforlife.org/index.php/resources/useful-links/
http://www.sri-online.org/links/educational-resources
http://www.rmhca.org/family-resources/helpful-links-for-families/
https://perinatalresources.org/medical-education-links/
http://aohna.org/resources-links/ohn-resources
http://ichpcolorado.com/services/Links_to_National_Health_Care_Resources.htm
http://www.healthystartbfg.com/Resources-Links.aspx
http://healthystartbfg.com/Resources-Links.aspx
http://www.ichpcolorado.com/services/Links_to_National_Health_Care_Resources.htm
http://tkeckle.net/links/medical.html
http://leavenfortheloaf.com/links/crisis-pregnancy-resources-in-nh/comment-page-1/#comments
http://leavenfortheloaf.com/links/crisis-pregnancy-resources-in-nh/
http://www.fitwise.com.au/patient-resources/links-page
http://www.parentingmatters-epc.org/parent-resources-support/helpful-links/
http://www.lifeslittletreasures.com.au/prematurity/useful-links/
http://leukodystrophyresourceresearch.org/resources-news/useful-links/
http://www.centralvalleymedicalcenter.com/resources/helpful-links
https://www.achancetogrowfilm.com/resources/resource-links/
http://wallofcourage.com/links/index.htm
http://www.wallofcourage.com/links/index.htm
http://myoc3.org/directory/catalog/companies/293?task=companies.showCompanyWebsite
http://www.myoc3.org/component/jbusinessdirectory/companies/293?task=companies.showCompanyWebsite
http://myoc3.org/component/jbusinessdirectory/companies/293?task=companies.showCompanyWebsite
http://www.arearlylearning.org/index.php/parents/parent-links/12
http://www.designedtobirth.com/links-books-and-resources.html
http://www.myoc3.org/directory/catalog/companies/293?task=companies.showCompanyWebsite
http://frontrangeobgyn.com/resources/links/
http://arearlylearning.org/index.php/parents/parent-links/12
http://www.arearlylearning.org/index.php/parents/parent-links?task=weblink.go&id=12
http://movingbeyondcancer.com.au/useful-links?task=weblink.go&id=14
http://www.motherandbabymatters.com/resources.html
http://arearlylearning.org/index.php/parents/parent-links?task=weblink.go&id=12
http://au.sascentre.com/resources/1323
http://int.sascentre.com/resources/1323
http://uk.sascentre.com/resources/1323
http://www.koruselfdevelopment.com/index.php/links/16
http://koruselfdevelopment.com/index.php/links/16
http://msoncologysociety.org/links-resources.php
http://www.msoncologysociety.org/links-resources.php
http://www.lifeslittletreasures.com.au/prematurity-resources/useful-links/
http://momchd.com/parenting-links-and-resources/
http://flintobgyn.com/patient-resources/links/
http://www.oxfordobgyninc.com/resources/related-links
http://livehealthysiouxland.org/web-links/8-prevention/73-cord-blood-banking.html
http://www.livehealthysiouxland.org/web-links/8-prevention/73-cord-blood-banking.html
http://getready4baby.com/links.html
http://www.getready4baby.com/links.html
http://jesperson.se/test1/magpierss/scripts/cache/43521fb1322467036d3b55ea1d37a921
http://jesperson.se/test1/magpierss/scripts/cache/43521fb1322467036d3b55ea1d37a921
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}