using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?([^\d])\.";
string input = @"Lorem 1. Foo, 23. Bar loalk fuu. Kakjfas ipsum fuia.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}