package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i).*\b[^\se]+\b.*`)
var str = `bed time
red carpet
god father
good game Al's here
test does this work, yes!
UPPERCASE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}