const regex = /.*\b[^\se]+\b.*/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\b[^\\se]+\\b.*', 'gi')
const str = `bed time
red carpet
god father
good game Al's here
test does this work, yes!
UPPERCASE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}