using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^>\([^()]*\):[^:]*:[^:]*:[^:]*:[^:\n]*$)(*SKIP)(*F)|^.+";
string input = @">(name1):database-ID:database2-ID:value1-1:value1-2
>(name2):database-ID:database2-ID:value2-1:value2-2
>(name3):database-ID:database2-ID:value3-1value3-2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}