$re = '/(?:^>\([^()]*\):[^:]*:[^:]*:[^:]*:[^:\n]*$)(*SKIP)(*F)|^.+/m';
$str = '>(name1):database-ID:database2-ID:value1-1:value1-2
>(name2):database-ID:database2-ID:value2-1:value2-2
>(name3):database-ID:database2-ID:value3-1value3-2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);