// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^>\([^()]*\):[^:]*:[^:]*:[^:]*:[^:\n]*$)(*SKIP)(*F)|^.+").unwrap();
let string = ">(name1):database-ID:database2-ID:value1-1:value1-2
>(name2):database-ID:database2-ID:value2-1:value2-2
>(name3):database-ID:database2-ID:value3-1value3-2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}