use strict;
my $str = 'https://www.partselect.com/PS11741913-Whirlpool-WP37001042-Drum-Support-Roller-for-square-ported-models.htm?Page=0#Central_Content_PagerTop
https://www.partselect.com/PS4138718-Samsung-DA34-00006C-Light-Door-Switch.htm?SourceCode=19&SearchTerm=&ModelNum=BBF19KASWXAC
https://www.partselect.com/PS9172714-MTD-954-04032B-Belt-3L-X-35-80.htm?SourceCode=18';
my $regex = qr/(http(s)?:\/\/)?(.*\\.)?partselect.com\/PS.*(htm|html)((?!Page=\d{1,3}#Central_Content_PagerTop).)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}