import re
regex = re.compile(r"(http(s)?:\/\/)?(.*\\.)?partselect.com\/PS.*(htm|html)((?!Page=\d{1,3}#Central_Content_PagerTop).)*$", flags=re.MULTILINE)
test_str = ("https://www.partselect.com/PS11741913-Whirlpool-WP37001042-Drum-Support-Roller-for-square-ported-models.htm?Page=0#Central_Content_PagerTop\n\n"
"https://www.partselect.com/PS4138718-Samsung-DA34-00006C-Light-Door-Switch.htm?SourceCode=19&SearchTerm=&ModelNum=BBF19KASWXAC\n\n"
"https://www.partselect.com/PS9172714-MTD-954-04032B-Belt-3L-X-35-80.htm?SourceCode=18")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")