import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\w+)";
final String string = "Tsuru Stork greeting for a long last life. Unisex\n"
+ "Yama Mountain; Restrainer; Unisex \n"
+ "Yuka A bright Star Unisex \n"
+ "Yumi A beautiful archery bow Unisex \n"
+ "Yuna The archer Unisex";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}