#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(19[5-9][0-9]|20[0-4][0-9]|2050)[-\/](0?[1-9]|1[0-2])[-\/](0?[1-9]|[12][0-9]|3[01])$"
Local $sString = "2011-11-15" & @CRLF & _
"2011-2-15" & @CRLF & _
"2006-01-05" & @CRLF & _
"2012-6-9" & @CRLF & _
"2011/11/15" & @CRLF & _
"2011/01/01" & @CRLF & _
"" & @CRLF & _
"2011/01/20" & @CRLF & _
"" & @CRLF & _
"2011/1/1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")