re = /^(19[5-9][0-9]|20[0-4][0-9]|2050)[-\/](0?[1-9]|1[0-2])[-\/](0?[1-9]|[12][0-9]|3[01])$/m
str = '2011-11-15
2011-2-15
2006-01-05
2012-6-9
2011/11/15
2011/01/01
2011/01/20
2011/1/1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end