import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(19[5-9][0-9]|20[0-4][0-9]|2050)[-\\/](0?[1-9]|1[0-2])[-\\/](0?[1-9]|[12][0-9]|3[01])$";
final String string = "2011-11-15\n"
+ "2011-2-15\n"
+ "2006-01-05\n"
+ "2012-6-9\n"
+ "2011/11/15\n"
+ "2011/01/01\n\n"
+ "2011/01/20\n\n"
+ "2011/1/1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}