$re = '/\d+\s?(X|x)|\s?\d+/m';
$str = '1234 x 2343
123x
x123
123 x
x 123
123X 123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);