import re
regex = re.compile(r"\d+\s?(X|x)|\s?\d+", flags=re.MULTILINE)
test_str = ("1234 x 2343\n\n"
"123x\n\n"
"x123\n\n"
"123 x\n\n"
"x 123\n\n"
"123X 123\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")