#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(<img.*src=["']cid:.+@[^"']+[^>]*(?|>|<\/img>)*)"
Local $sString = "fewerwrwer<img title="test" src="cid:imagename.jpg@abcdefgh"></img>asdasdasdafewerwrwer<img title="test" src="cid:imagename.jpg@abcdefgh"></img>asdasdasda"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")