$re = '/(<img.*src=["\']cid:.+@[^"\']+[^>]*(?|>|<\/img>)*)/i';
$str = 'fewerwrwer<img title="test" src="cid:imagename.jpg@abcdefgh"></img>asdasdasdafewerwrwer<img title="test" src="cid:imagename.jpg@abcdefgh"></img>asdasdasda';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);