using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<img.*src=[""']cid:.+@[^""']+[^>]*(?|>|<\/img>)*)";
string input = @"fewerwrwer<img title=""test"" src=""cid:imagename.jpg@abcdefgh""></img>asdasdasdafewerwrwer<img title=""test"" src=""cid:imagename.jpg@abcdefgh""></img>asdasdasda";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}