$re = '/(e[0-9]r[0-9]{1,2}p[0-9]{1,2})/';
$str = 'e2r1p1.42.fr';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);