import Foundation
let pattern = #"(e[0-9]r[0-9]{1,2}p[0-9]{1,2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"e2r1p1.42.fr"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}