const regex = /\b(xra\w+)\b/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(xra\\w+)\\b', 'i')
const str = `I want to sell XRAY machine of Philips in a good c...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}