$re = '/\b(xra\w+)\b/i';
$str = 'I want to sell XRAY machine of Philips in a good c...';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);