re = /\b(xra\w+)\b/i
str = 'I want to sell XRAY machine of Philips in a good c...'
# Print the match result
str.match(re) do |match|
puts match.to_s
end