using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"__(\d+)(\.\d+)*__";
string input = @"__1.23.1__
__1.2__
__1.__
__12__
__.4__
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}