$re = '/__(\d+)(\.\d+)*__/';
$str = '__1.23.1__
__1.2__
__1.__
__12__
__.4__
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);