import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a[^>]*>#[^<#]*<\\/a>";
final String string = "<p><a href=\"/user/username\" >Username</a> #filmphotography #vintage <a href=\"/tag/travelgram\" >#travelgram</a> #montreux #royalpalacehotel <a href=\"/tag/switzerland\">#switzerland</a> #selfie <a href=\"/tag/meandmysister\">#meandmysister</a></p>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}