import Foundation
let pattern = ##"<a[^>]*>#[^<#]*<\/a>"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<p><a href="/user/username" >Username</a> #filmphotography #vintage <a href="/tag/travelgram" >#travelgram</a> #montreux #royalpalacehotel <a href="/tag/switzerland">#switzerland</a> #selfie <a href="/tag/meandmysister">#meandmysister</a></p>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)