$re = '/<a[^>]*>#[^<#]*<\/a>/m';
$str = '<p><a href="/user/username" >Username</a> #filmphotography #vintage <a href="/tag/travelgram" >#travelgram</a> #montreux #royalpalacehotel <a href="/tag/switzerland">#switzerland</a> #selfie <a href="/tag/meandmysister">#meandmysister</a></p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);