#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\s)1(?=[A-Za-z])"
Local $sString = "-ABC046Y 1SMITH/FREDMR " & @CRLF & _
".L/JCD5CQ " & @CRLF & _
".R/TKNE HK1 6002300348396/1-SMITH/FREDMR " & @CRLF & _
".R/SEAT HK1 9F " & @CRLF & _
".R/FQTV AB 60042576-1SMITH/FREDMR 1DOE/JANEMISS " & @CRLF & _
".L/JC93QW " & @CRLF & _
".R/TKNE HK1 6002300219029/2-1DOE/JANEEMISS " & @CRLF & _
".R/SEAT HK1 8A " & @CRLF & _
".R/CHKD HK1 011-1DOE/JANEMISS 1PRESLEY/ELVISMR-A2 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")