import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s)1(?=[A-Za-z])";
final String string = "-ABC046Y 1SMITH/FREDMR \n"
+ ".L/JCD5CQ \n"
+ ".R/TKNE HK1 6002300348396/1-SMITH/FREDMR \n"
+ ".R/SEAT HK1 9F \n"
+ ".R/FQTV AB 60042576-1SMITH/FREDMR 1DOE/JANEMISS \n"
+ ".L/JC93QW \n"
+ ".R/TKNE HK1 6002300219029/2-1DOE/JANEEMISS \n"
+ ".R/SEAT HK1 8A \n"
+ ".R/CHKD HK1 011-1DOE/JANEMISS 1PRESLEY/ELVISMR-A2 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}