import re
regex = re.compile(r"(?<=\s)1(?=[A-Za-z])", flags=re.MULTILINE)
test_str = ("-ABC046Y 1SMITH/FREDMR \n"
".L/JCD5CQ \n"
".R/TKNE HK1 6002300348396/1-SMITH/FREDMR \n"
".R/SEAT HK1 9F \n"
".R/FQTV AB 60042576-1SMITH/FREDMR 1DOE/JANEMISS \n"
".L/JC93QW \n"
".R/TKNE HK1 6002300219029/2-1DOE/JANEEMISS \n"
".R/SEAT HK1 8A \n"
".R/CHKD HK1 011-1DOE/JANEMISS 1PRESLEY/ELVISMR-A2 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")