use strict;
my $str = '0.0.0.0
1.1.1.1
9.9.9.9
10.10.10.10
99.99.99.99
100.100.100.100
199.199.199.199
200.200.200.200
255.255.255.255
256.256.256.256
1.1.1.1.1
foo.bar.baz.qux';
my $regex = qr/^(?:(?:\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])\.){3}(?:\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])$/mp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}