re = /^(?:(?:\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])\.){3}(?:\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])$/m
str = '0.0.0.0
1.1.1.1
9.9.9.9
10.10.10.10
99.99.99.99
100.100.100.100
199.199.199.199
200.200.200.200
255.255.255.255
256.256.256.256
1.1.1.1.1
foo.bar.baz.qux'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end