#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=[href|src]=")https?:\/\/.*?(?=")"
Local $sString = "<img src="С голубочком.jpg" alt="Slide 1" class="SashaIcons" width="697" height="479" />" & @CRLF & _
" 94: <img src="http://kristinita.ru/404_files/У_реки.jpg" alt="Slide 2" class="SashaIcons" width="697" height="479" />" & @CRLF & _
" 95: <img src="http://kristinita.ru/404_files/Шимский_район_Новгорода.jpg" alt="Slide 3" class="SashaIcons" width="697" height="479" />" & @CRLF & _
" 96: <img src="404_files/Бантик.jpg" alt="Slide 4" class="SashaIcons" width="697" height="479" />" & @CRLF & _
"" & @CRLF & _
"<li><a href="#Valerywork">Вэлериворк</a>" & @CRLF & _
" </li>" & @CRLF & _
" <li><a href="#TermValerywork">Употребление термина Valerywork</a>" & @CRLF & _
" </li>" & @CRLF & _
" <li><a href="../Kiravel">Киравэл</a>" & @CRLF & _
" </li>" & @CRLF & _
" <li><a href="#TermKiravel">Kirave и терминология</a>" & @CRLF & _
" </li>" & @CRLF & _
" <li><a href="#Strelena">Стрелена</a>" & @CRLF & _
" </li>" & @CRLF & _
" <br />" & @CRLF & _
" <br />" & @CRLF & _
" <h2 id="Valerywork">Вэлериворк</h2>" & @CRLF & _
" <br /> Представим, что о природе чёрных дыр рассуждают Стивен Хокинг с неким бизнесменом. Первый посвятил изучению этих объектов жизнь, вникнув во все тонкости и сложности, второй решил, что их возникновение приходится на поедание <a href="http://anima-kommunizm.forum2x2.ru/t36-topic" target="_blank" title="Либербизон">либербизоном</a> собственных детей. Оба мнения базируются на том, что содержится в головах у их носителей. Так вот это «что в головах», <u>среда накопления, обработки и группирования информации; система понятий и причинно-следственных связей между ними, на основе которых выражаются мнения и оценки</u>, называется <b>Вэлериворк</b> (от <a href="https://vk.com/zombelina" target="_blank" title="Страница Валерии ВК">Валерия</a> и <a href="https://rsdn.ru/article/patterns/framework.xml#EKB" target="_blank" title="Определение Framework">Framework</a>, также" & @CRLF & _
" <SashaDot>BW</SashaDot>," & @CRLF & _
" <SashaDot>Пространство Понятий</SashaDot>," & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")