import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[href|src]=\")https?:\\/\\/.*?(?=\")";
final String string = "<img src=\"С голубочком.jpg\" alt=\"Slide 1\" class=\"SashaIcons\" width=\"697\" height=\"479\" />\n"
+ " 94: <img src=\"http://kristinita.ru/404_files/У_реки.jpg\" alt=\"Slide 2\" class=\"SashaIcons\" width=\"697\" height=\"479\" />\n"
+ " 95: <img src=\"http://kristinita.ru/404_files/Шимский_район_Новгорода.jpg\" alt=\"Slide 3\" class=\"SashaIcons\" width=\"697\" height=\"479\" />\n"
+ " 96: <img src=\"404_files/Бантик.jpg\" alt=\"Slide 4\" class=\"SashaIcons\" width=\"697\" height=\"479\" />\n\n"
+ "<li><a href=\"#Valerywork\">Вэлериворк</a>\n"
+ " </li>\n"
+ " <li><a href=\"#TermValerywork\">Употребление термина Valerywork</a>\n"
+ " </li>\n"
+ " <li><a href=\"../Kiravel\">Киравэл</a>\n"
+ " </li>\n"
+ " <li><a href=\"#TermKiravel\">Kirave и терминология</a>\n"
+ " </li>\n"
+ " <li><a href=\"#Strelena\">Стрелена</a>\n"
+ " </li>\n"
+ " <br />\n"
+ " <br />\n"
+ " <h2 id=\"Valerywork\">Вэлериворк</h2>\n"
+ " <br /> Представим, что о природе чёрных дыр рассуждают Стивен Хокинг с неким бизнесменом. Первый посвятил изучению этих объектов жизнь, вникнув во все тонкости и сложности, второй решил, что их возникновение приходится на поедание <a href=\"http://anima-kommunizm.forum2x2.ru/t36-topic\" target=\"_blank\" title=\"Либербизон\">либербизоном</a> собственных детей. Оба мнения базируются на том, что содержится в головах у их носителей. Так вот это «что в головах», <u>среда накопления, обработки и группирования информации; система понятий и причинно-следственных связей между ними, на основе которых выражаются мнения и оценки</u>, называется <b>Вэлериворк</b> (от <a href=\"https://vk.com/zombelina\" target=\"_blank\" title=\"Страница Валерии ВК\">Валерия</a> и <a href=\"https://rsdn.ru/article/patterns/framework.xml#EKB\" target=\"_blank\" title=\"Определение Framework\">Framework</a>, также\n"
+ " <SashaDot>BW</SashaDot>,\n"
+ " <SashaDot>Пространство Понятий</SashaDot>,\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}