$re = '/(?<=[href|src]=")https?:\/\/.*?(?=")/';
$str = '<img src="С голубочком.jpg" alt="Slide 1" class="SashaIcons" width="697" height="479" />
94: <img src="http://kristinita.ru/404_files/У_реки.jpg" alt="Slide 2" class="SashaIcons" width="697" height="479" />
95: <img src="http://kristinita.ru/404_files/Шимский_район_Новгорода.jpg" alt="Slide 3" class="SashaIcons" width="697" height="479" />
96: <img src="404_files/Бантик.jpg" alt="Slide 4" class="SashaIcons" width="697" height="479" />
<li><a href="#Valerywork">Вэлериворк</a>
</li>
<li><a href="#TermValerywork">Употребление термина Valerywork</a>
</li>
<li><a href="../Kiravel">Киравэл</a>
</li>
<li><a href="#TermKiravel">Kirave и терминология</a>
</li>
<li><a href="#Strelena">Стрелена</a>
</li>
<br />
<br />
<h2 id="Valerywork">Вэлериворк</h2>
<br /> Представим, что о природе чёрных дыр рассуждают Стивен Хокинг с неким бизнесменом. Первый посвятил изучению этих объектов жизнь, вникнув во все тонкости и сложности, второй решил, что их возникновение приходится на поедание <a href="http://anima-kommunizm.forum2x2.ru/t36-topic" target="_blank" title="Либербизон">либербизоном</a> собственных детей. Оба мнения базируются на том, что содержится в головах у их носителей. Так вот это «что в головах», <u>среда накопления, обработки и группирования информации; система понятий и причинно-следственных связей между ними, на основе которых выражаются мнения и оценки</u>, называется <b>Вэлериворк</b> (от <a href="https://vk.com/zombelina" target="_blank" title="Страница Валерии ВК">Валерия</a> и <a href="https://rsdn.ru/article/patterns/framework.xml#EKB" target="_blank" title="Определение Framework">Framework</a>, также
<SashaDot>BW</SashaDot>,
<SashaDot>Пространство Понятий</SashaDot>,
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);