use strict;
my $str = 'I want to use regex to check if an HTML document contains at least one of all the tags below:
<b> [content1] </b>
and
<i> [content2] </i>
and
<b> [content3] <i> [content4] </i> [content5] </b>
or
<i> [content6] <b> [content7] </b> [content8] </i>
\'content\' can be anything. Is there a way to achieve this';
my $regex = qr/<([bi])>.*<\/\1>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}