re = /<([bi])>.*<\/\1>/m
str = 'I want to use regex to check if an HTML document contains at least one of all the tags below:
<b> [content1] </b>
and
<i> [content2] </i>
and
<b> [content3] <i> [content4] </i> [content5] </b>
or
<i> [content6] <b> [content7] </b> [content8] </i>
\'content\' can be anything. Is there a way to achieve this'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end