import Foundation
let pattern = #"<([bi])>.*<\/\1>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
I want to use regex to check if an HTML document contains at least one of all the tags below:
<b> [content1] </b>
and
<i> [content2] </i>
and
<b> [content3] <i> [content4] </i> [content5] </b>
or
<i> [content6] <b> [content7] </b> [content8] </i>
'content' can be anything. Is there a way to achieve this
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)